CMakeLists.txt

changeset 316
dcd472be9ae8
parent 314
04b93b656b60
child 318
ff02aca2b63c
--- a/CMakeLists.txt	Wed Jun 29 08:44:57 2022 +0200
+++ b/CMakeLists.txt	Wed Jun 29 21:28:13 2022 +0200
@@ -138,6 +138,58 @@
     ${GEN_MOC_FILES3}
   )
 
+  QT_WRAP_CPP(GEN_MOC_FILES4
+    ${SRCDIR}/analog/thermometer.h
+    ${SRCDIR}/analog/abstractmeter.h
+    ${SRCDIR}/analog/widgetwithbackground.h
+    designer/thermometer_plugin.h
+  )
+  add_library(bmsapp_thermometer SHARED
+    ${SRCDIR}/analog/thermometer.cpp
+    ${SRCDIR}/analog/abstractmeter.cpp
+    ${SRCDIR}/analog/widgetwithbackground.cpp
+    designer/thermometer_plugin.cpp
+    ${GEN_MOC_FILES4}
+  )
+
+  QT_WRAP_CPP(GEN_MOC_FILES5
+    ${SRCDIR}/analog/manometer.h
+    ${SRCDIR}/analog/abstractmeter.h
+    ${SRCDIR}/analog/widgetwithbackground.h
+    designer/manometer_plugin.h
+  )
+  add_library(bmsapp_manometer SHARED
+    ${SRCDIR}/analog/manometer.cpp
+    ${SRCDIR}/analog/abstractmeter.cpp
+    ${SRCDIR}/analog/widgetwithbackground.cpp
+    designer/manometer_plugin.cpp
+    ${GEN_MOC_FILES5}
+  )
+
+  QT_WRAP_CPP(GEN_MOC_FILES6
+    ${SRCDIR}/analog/wallclock.h
+    ${SRCDIR}/analog/widgetwithbackground.h
+    designer/wallclock_plugin.h
+  )
+  add_library(bmsapp_wallclock SHARED
+    ${SRCDIR}/analog/wallclock.cpp
+    ${SRCDIR}/analog/widgetwithbackground.cpp
+    designer/wallclock_plugin.cpp
+    ${GEN_MOC_FILES6}
+  )
+
+  QT_WRAP_CPP(GEN_MOC_FILES7
+    ${SRCDIR}/analog/led.h
+    ${SRCDIR}/analog/widgetwithbackground.h
+    designer/led_plugin.h
+  )
+  add_library(bmsapp_led SHARED
+    ${SRCDIR}/analog/led.cpp
+    ${SRCDIR}/analog/widgetwithbackground.cpp
+    designer/led_plugin.cpp
+    ${GEN_MOC_FILES7}
+  )
+
 ELSE()
 
   set( SRCS
@@ -189,6 +241,13 @@
     ${SRCDIR}/RangedSlider.cpp
     ${SRCDIR}/NullDateEdit.cpp
     ${SRCDIR}/LED.cpp
+    ${SRCDIR}/analog/abstractmeter.cpp
+    ${SRCDIR}/analog/functions.cpp
+    ${SRCDIR}/analog/widgetwithbackground.cpp
+    ${SRCDIR}/analog/manometer.cpp
+    ${SRCDIR}/analog/thermometer.cpp
+    ${SRCDIR}/analog/led.cpp
+    ${SRCDIR}/analog/wallclock.cpp
     ${SRCDIR}/global.cpp
   )
 
@@ -240,6 +299,13 @@
     ${SRCDIR}/RangedSlider.h
     ${SRCDIR}/NullDateEdit.h
     ${SRCDIR}/LED.h
+    ${SRCDIR}/analog/abstractmeter.h
+    ${SRCDIR}/analog/functions.h
+    ${SRCDIR}/analog/widgetwithbackground.h
+    ${SRCDIR}/analog/manometer.h
+    ${SRCDIR}/analog/thermometer.h
+    ${SRCDIR}/analog/led.h
+    ${SRCDIR}/analog/wallclock.h
     ${SRCDIR}/global.h
   )
 
@@ -310,8 +376,15 @@
 
 IF( ${BUILD_DESIGNER_PLUGINS} )
 
-	INSTALL(TARGETS bmsapp_rangeslider bmsapp_nulldate bmsapp_LED
-	DESTINATION "${LIBPATH}/plugins/designer"
+  INSTALL(TARGETS
+    bmsapp_rangeslider
+    bmsapp_nulldate
+    bmsapp_LED
+    bmsapp_thermometer
+    bmsapp_manometer
+    bmsapp_led
+    bmsapp_wallclock
+    DESTINATION "${LIBPATH}/plugins/designer"
   )
 
 ELSE()

mercurial