CMakeLists.txt

branch
idf 5.1
changeset 129
31f9d3e4a85f
parent 127
e86ee2d718b2
child 136
89fc3c57282e
--- a/CMakeLists.txt	Mon Feb 19 15:07:28 2024 +0100
+++ b/CMakeLists.txt	Mon Jun 24 17:05:20 2024 +0200
@@ -1,9 +1,22 @@
 # The following lines of boilerplate have to be in your project's CMakeLists
 # in this exact order for cmake to work correctly
-cmake_minimum_required(VERSION 3.5)
+cmake_minimum_required(VERSION 3.16)
+
+#project(brewboard VERSION 0.3.24)
+
+#find_package(EXPAT 2.6.2 MODULE REQUIRED)
+
+#add_executable(brewboard
+#    hello.c
+#)
+
 
 set(PROJECT_VER "0.3.24")
 set(PROJECT_NAME "brewboard")
 
+
+#target_link_libraries(brewboard PUBLIC expat::expat)
+
+set(EXTRA_COMPONENT_DIRS components/esp32-ds18b20 components/esp32-owb components/PID components/spidriver components/tft components/websocket)
 include($ENV{IDF_PATH}/tools/cmake/project.cmake)
 project(brewboard)

mercurial