components/esp32-owb/CMakeLists.txt

branch
idf 5.1
changeset 129
31f9d3e4a85f
parent 74
cba50f7529d0
--- a/components/esp32-owb/CMakeLists.txt	Mon Feb 19 15:07:28 2024 +0100
+++ b/components/esp32-owb/CMakeLists.txt	Mon Jun 24 17:05:20 2024 +0200
@@ -1,2 +1,12 @@
-idf_component_register(SRCS owb_rmt.c owb.c owb_gpio.c INCLUDE_DIRS include)
+if (NOT IDF_VERSION_MAJOR)
+  set(IDF_VERSION_MAJOR 3)
+endif()
 
+if (IDF_VERSION_MAJOR LESS 5)
+    message(FATAL_ERROR "Can't build: requires ESP-IDF version 5.0 or above.")
+endif()
+
+set(COMPONENT_ADD_INCLUDEDIRS include)
+set(COMPONENT_SRCS "owb.c" "owb_gpio.c" "owb_rmt.c")
+set(COMPONENT_REQUIRES "soc" "driver" "esp_rom")
+register_component()

mercurial