configure.ac

changeset 550
04c942cded91
parent 549
ee1bcad035f0
child 551
3721f9c08843
--- a/configure.ac	Sat Jul 21 20:40:02 2018 +0200
+++ b/configure.ac	Mon Jul 23 14:41:21 2018 +0200
@@ -8,7 +8,7 @@
 dnl General settings
 dnl After changeing the version number, run autoconf!
 PACKAGE="mbsePi-apps"
-VERSION="0.8.2"
+VERSION="0.8.3"
 COPYRIGHT="Copyright (C) 2014-2018 Michiel Broek, All Rights Reserved"
 CYEARS="2014-2018"
 AC_SUBST(PACKAGE)
@@ -46,6 +46,14 @@
   AC_CHECK_HEADERS(wiringPi.h,WIRINGPI=Yes,WIRINGPI=No)
 fi
 
+AC_CHECK_LIB(json-c,json_object_iter_init_default,result=yes,result=no)
+if test "$result" = "yes"; then
+  LIBS="$LIBS -ljson-c"
+  AC_CHECK_HEADERS(json-c/json.h)
+else
+  AC_MSG_ERROR(json-c not found)
+fi
+
 #
 # Additional commandline switches
 #

mercurial