configure.ac

changeset 142
4f21ffc16cd4
parent 107
f2f201b7cb48
child 144
3446371e0bdb
--- a/configure.ac	Sun Jul 27 21:04:57 2014 +0200
+++ b/configure.ac	Mon Jul 28 21:41:03 2014 +0200
@@ -8,7 +8,7 @@
 dnl General settings
 dnl After changeing the version number, run autoconf!
 PACKAGE="mbsePi-apps"
-VERSION="0.0.10"
+VERSION="0.0.11"
 COPYRIGHT="Copyright (C) 2014 Michiel Broek, All Rights Reserved"
 CYEARS="2014"
 AC_SUBST(PACKAGE)
@@ -46,6 +46,13 @@
   AC_CHECK_HEADERS(wiringPi.h,WIRINGPI=Yes,WIRINGPI=No)
 fi
 
+OWSERVER=No
+AC_CHECK_LIB(ownet,OWNET_init,result=yes,result=no)
+if test "$result" = "yes"; then
+  LIBS="$LIBS -lownet"
+  AC_CHECK_HEADERS(ownetapi.h,OWSERVER=Yes,OWSERVER=No)
+fi
+
 
 #
 # Additional commandline switches
@@ -100,6 +107,7 @@
     Version : ............ ${VERSION}
     Main directory : ..... ${prefix}
     WiringPi : ........... ${WIRINGPI}
+    OWserver : ........... ${OWSERVER}
 
   Now type 'make' and 'sudo make install'
 ])

mercurial