configure.ac

changeset 675
825210ba2707
parent 673
0c084b876a2c
child 691
cfe13185fd02
--- a/configure.ac	Thu Apr 11 15:58:49 2024 +0200
+++ b/configure.ac	Sat Apr 13 16:50:26 2024 +0200
@@ -2,7 +2,7 @@
 
 AC_INIT(thermferm/thermferm.c)
 AM_CONFIG_HEADER(config.h)
-SUBDIRS="thermferm brewpanel tools"
+SUBDIRS="thermferm brewpanel tools www"
 AC_SUBST(SUBDIRS)
 
 dnl General settings
@@ -60,6 +60,15 @@
   AC_MSG_ERROR(json-c not found)
 fi
 
+AC_CHECK_LIB(websockets,lws_create_context,result=yes,result=no)
+if test "$result" = "yes"; then
+  LIBS="$LIBS -lwebsockets"
+  AC_CHECK_HEADERS(libwebsockets.h)
+else
+  AC_MSG_ERROR(libwebsockets not found)
+fi
+
+
 #
 # Additional commandline switches
 #
@@ -156,6 +165,7 @@
 
 AC_OUTPUT(
     Makefile.global
+    www/version.php
 )
 
 AC_MSG_RESULT([

mercurial