configure.ac

changeset 726
8289078ff7be
parent 725
b15a2ae7bea7
child 727
78744b7e6021
--- a/configure.ac	Sat May 04 15:43:37 2024 +0200
+++ b/configure.ac	Sat May 04 17:37:47 2024 +0200
@@ -29,6 +29,7 @@
 AC_CHECK_PROG(INSTALL, install, install)
 AC_CHECK_PROG(TAR, tar, tar)
 
+
 #
 # Libraries for mbsePi-apps
 #
@@ -92,6 +93,11 @@
 fi
 LIBS="$LIBS -lm"
 
+AC_CHECK_DECLS(gettid,result=yes,result=no)
+if test "$result" = "yes"; then
+  AC_DEFINE(HAVE_GETTID)
+fi
+
 
 AC_CHECK_LIB(xml2,xmlParseFile,result=yes,result=no)
 if test "$result" = "yes"; then

mercurial