configure.ac

changeset 51
a03b6dac5398
parent 41
f534ace74eea
child 57
a76dc0db592c
--- a/configure.ac	Sun May 25 16:39:54 2014 +0200
+++ b/configure.ac	Sun May 25 22:06:56 2014 +0200
@@ -1,14 +1,14 @@
 dnl Process this file with autoconf to produce a configure script.
 
-AC_INIT(thermometers/main.c)
+AC_INIT(thermometers/thermometers.c)
 AM_CONFIG_HEADER(config.h)
-SUBDIRS="lib dht11 rc433 thermferm thermometers"
+SUBDIRS="dht11 rc433 thermferm thermometers"
 AC_SUBST(SUBDIRS)
 
 dnl General settings
 dnl After changeing the version number, run autoconf!
 PACKAGE="mbsePi-apps"
-VERSION="0.0.6"
+VERSION="0.0.7"
 COPYRIGHT="Copyright (C) 2014 Michiel Broek, All Rights Reserved"
 CYEARS="2014"
 AC_SUBST(PACKAGE)
@@ -34,7 +34,7 @@
 #
 AC_CHECK_LIB(mosquitto,mosquitto_lib_init,result=yes,result=no)
 if test "$result" = "yes"; then
-  LIBS="$LIBS -lmosquitto"
+  AC_CHECK_HEADERS(mosquitto.h,MOSQUITTO=Yes,MOSQUITTO=No)
 else
   AC_MSG_ERROR(libmosquitto not found)
 fi

mercurial