configure.ac

changeset 0
ac8e19023b12
child 6
9db76e20e21e
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/configure.ac	Tue Apr 22 16:34:02 2014 +0200
@@ -0,0 +1,69 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(thermometers/main.c)
+AM_CONFIG_HEADER(config.h)
+SUBDIRS="thermometers"
+AC_SUBST(SUBDIRS)
+
+dnl General settings
+dnl After changeing the version number, run autoconf!
+PACKAGE="mbsePi-apps"
+VERSION="0.0.0"
+COPYRIGHT="Copyright (C) 2014 Michiel Broek, All Rights Reserved"
+CYEARS="2014"
+AC_SUBST(PACKAGE)
+AC_SUBST(VERSION)
+AC_SUBST(COPYRIGHT)
+AC_SUBST(CYEARS)
+AC_PREFIX_DEFAULT(/usr/local)
+AC_DEFINE_UNQUOTED(VERSION, "$VERSION")
+AC_DEFINE_UNQUOTED(COPYRIGHT, "$COPYRIGHT")
+TARGET="$target"
+
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_RANLIB
+dnl Try to find GNU install
+AC_CHECK_PROG(INSTALL, ginstall, ginstall)
+AC_CHECK_PROG(INSTALL, install, install)
+dnl AC_PROG_MAKE_SET
+AC_CHECK_PROG(TAR, tar, tar)
+
+#
+# Additional commandline switches
+#
+AC_ARG_ENABLE(experiment,  [  --enable-experiment     Compile experimental code],     [ experiment=$enableval ], [ experiment=no ])
+if test "$experiment" = "yes"; then
+  AC_DEFINE(USE_EXPERIMENT)
+fi
+
+AC_ARG_ENABLE(debugging,   [  --enable-debugging      Compile for debugging], [ debugging=$enableval ], [ debugging=no ])
+if test "$debugging" = "yes"; then
+  CFLAGS="-O -g -Wall -Wshadow -Wwrite-strings -Wstrict-prototypes -Winline"    
+else
+  CFLAGS="-g -O2 -fomit-frame-pointer -fno-strict-aliasing -Wall -Wshadow -Wwrite-strings -Wstrict-prototypes -Winline"
+fi
+
+dnl Checks for header files.
+AC_HEADER_STDC
+
+
+AC_SUBST(CXXFLAGS)
+
+
+AC_OUTPUT(
+    Makefile.global
+)
+
+AC_MSG_RESULT([
+-=-=-=-=-=-=-=-=-=-= Configuration Complete =-=-=-=-=-=-=-=-=-=-
+
+  Configuration summary :
+
+    Version : ............ ${VERSION}
+    Main directory : ..... ${prefix}
+
+  Now type 'make' and 'sudo make install'
+])
+

mercurial