configure.ac

changeset 557
ae17042a6d39
parent 554
ab9f22ab57b5
child 561
fcfc3dbe85fa
--- a/configure.ac	Wed Aug 01 22:27:58 2018 +0200
+++ b/configure.ac	Thu Aug 02 12:20:06 2018 +0200
@@ -8,7 +8,7 @@
 dnl General settings
 dnl After changeing the version number, run autoconf!
 PACKAGE="mbsePi-apps"
-VERSION="0.8.5"
+VERSION="0.8.6"
 COPYRIGHT="Copyright (C) 2014-2018 Michiel Broek, All Rights Reserved"
 CYEARS="2014-2018"
 AC_SUBST(PACKAGE)
@@ -32,11 +32,12 @@
 #
 # Libraries for mbsePi-apps
 #
-MOSQUITTO=No
 AC_CHECK_LIB(mosquitto,mosquitto_lib_init,result=yes,result=no)
 if test "$result" = "yes"; then
-  AC_CHECK_HEADERS(mosquitto.h,MOSQUITTO=Yes,MOSQUITTO=No)
+  AC_CHECK_HEADERS(mosquitto.h)
   LIBS="$LIBS -lmosquitto"
+else
+  AC_MSG_ERROR(mosquitto not found)
 fi
 
 WIRINGPI=No
@@ -157,7 +158,6 @@
     Version : ............ ${VERSION}
     Main directory : ..... ${prefix}
     WiringPi : ........... ${WIRINGPI}
-    MQTT : ............... ${MOSQUITTO}
     SDL library : ........ ${SDL}
     Simulator : .......... ${SIMULATOR}
 

mercurial