configure.ac

changeset 283
affe4d2adc94
parent 262
d0014ccec615
child 290
edb0b4da491a
--- a/configure.ac	Tue Sep 02 16:37:43 2014 +0200
+++ b/configure.ac	Tue Sep 02 16:54:18 2014 +0200
@@ -8,7 +8,7 @@
 dnl General settings
 dnl After changeing the version number, run autoconf!
 PACKAGE="mbsePi-apps"
-VERSION="0.2.1"
+VERSION="0.2.2"
 COPYRIGHT="Copyright (C) 2014 Michiel Broek, All Rights Reserved"
 CYEARS="2014"
 AC_SUBST(PACKAGE)
@@ -47,9 +47,11 @@
   AC_DEFINE(USE_EXPERIMENT)
 fi
 
+SIMULATOR=No
 AC_ARG_ENABLE(simulator,  [  --enable-simulator      Compile simulator code], [ simulator=$enableval ], [ simulator=no ])
 if test "$simulator" = "yes"; then
   AC_DEFINE(USE_SIMULATOR)
+  SIMULATOR=Yes
 fi
 
 AC_ARG_ENABLE(debugging,   [  --enable-debugging      Compile for debugging], [ debugging=$enableval ], [ debugging=no ])
@@ -98,6 +100,7 @@
     Version : ............ ${VERSION}
     Main directory : ..... ${prefix}
     WiringPi : ........... ${WIRINGPI}
+    Simulator : .......... ${SIMULATOR}
 
   Now type 'make' and 'sudo make install'
 ])

mercurial