configure.ac

changeset 259
b7c967359771
parent 250
a21865cb1ef4
child 262
d0014ccec615
--- a/configure.ac	Wed Aug 20 22:15:12 2014 +0200
+++ b/configure.ac	Fri Aug 22 17:12:42 2014 +0200
@@ -8,7 +8,7 @@
 dnl General settings
 dnl After changeing the version number, run autoconf!
 PACKAGE="mbsePi-apps"
-VERSION="0.2.0"
+VERSION="0.2.1"
 COPYRIGHT="Copyright (C) 2014 Michiel Broek, All Rights Reserved"
 CYEARS="2014"
 AC_SUBST(PACKAGE)
@@ -47,6 +47,11 @@
   AC_DEFINE(USE_EXPERIMENT)
 fi
 
+AC_ARG_ENABLE(simulator,  [  --enable-simulator      Compile simulator code], [ simulator=$enableval ], [ simulator=no ])
+if test "$simulator" = "yes"; then
+  AC_DEFINE(USE_SIMULATOR)
+fi
+
 AC_ARG_ENABLE(debugging,   [  --enable-debugging      Compile for debugging], [ debugging=$enableval ], [ debugging=no ])
 if test "$debugging" = "yes"; then
   CFLAGS="-O -g -Wall -Wshadow -Wwrite-strings -Wstrict-prototypes -Winline"    

mercurial