configure.ac

changeset 16
f4cbe008da72
parent 13
7f8432413321
child 17
b802305046dc
--- a/configure.ac	Tue Apr 29 20:57:16 2014 +0200
+++ b/configure.ac	Fri May 02 21:04:20 2014 +0200
@@ -8,7 +8,7 @@
 dnl General settings
 dnl After changeing the version number, run autoconf!
 PACKAGE="mbsePi-apps"
-VERSION="0.0.1"
+VERSION="0.0.2"
 COPYRIGHT="Copyright (C) 2014 Michiel Broek, All Rights Reserved"
 CYEARS="2014"
 AC_SUBST(PACKAGE)
@@ -40,6 +40,14 @@
   AC_MSG_ERROR(libmosquitto not found)
 fi
 
+AC_CHECK_LIB(wiringPi,wiringPiSetup,result=yes,result=no)
+if test "$result" = "yes"; then
+  LIBS="$LIBS -lwiringPi -lwiringPiDev"
+else
+  AC_MSG_ERROR(libwiringPi not found)
+fi
+
+
 #
 # Additional commandline switches
 #

mercurial